
Animating with Flash

While Flash MX 2004 and Flash MX Professional 2004 have evolved into full-fledged

interactive design tools suitable for creating a whole range of groovy media, Flash is, at its

heart, still an animation program. Flash’s core feature, vector-based graphics, really shines

when it comes to animation. As a result, it behooves you to become intimately familiar with

all the ways you can infuse your beautiful Flash creation with movement.

In this part of the book, you’ll learn almost everything you need to know about the fun-

damentals of animating in Flash. You’ll start by looking at how to use the Timeline to make

your creation zip, bounce, zing, and jump. From there, you’ll explore one of the most

important aspects of animating in Flash: Movie Clips (a topic that is vital to your future

adventures in ActionScripting).You’ll then explore one of the most useful tools you can use

to control, manage, and manipulate your animation: Scenes. You’ll finish Part III by

exploring a new feature in Flash MX Pro 2004 that allows you to create Flash movies using

a slide metaphor.

CHAPTER 10 ■ Animating with the Timeline

CHAPTER 11 ■ Working with Movie Clips

CHAPTER 12 ■ Using Scenes to Organize Your Flash Movie

CHAPTER 13 ■ Creating Interactive Presentations with Slides 
in Flash MX Professional 2004
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Animating with the Timeline

FutureSplash (later to become Flash) was a simple vector-animation pro-

gram when Macromedia acquired it from FutureWave back in 1997. Though the most

recent version of Flash has about 100 times the bells and whistles that FutureSplash did, 

it is still, at its core, an animation program. Although you can do much more than ani-

mate objects, much of the power of Flash MX 2004 and Flash MX Pro 2004 lies in the

ability to create movies with content that changes over time.

Until this point, you haven’t created anything that moves (unless you’ve shaken your

computer monitor around). If you had wanted to create only static images, you could

have easily turned to Macromedia Fireworks or Adobe Photoshop. But, no, you want to

make things that move and spin and bounce! Whether it’s a character that walks across the

screen and promptly gets hit by a falling anvil or a button that spins around when users

move their cursors over it, you want to create animations. In this chapter, you’ll explore

the primary tool you use to construct and manipulate animations in Flash MX 2004 and

Flash MX Pro 2004: the Timeline.

Topics include the following:

■ Understanding the subtle art of animation

■ Creating frame-by-frame animations

■ Creating tweened animations

■ Animating a mask

■ Extending a still image through time

■ Animating a Symbol Instance’s Visual Properties 
with the Property Inspector

■ Animating with Timeline Effects

C H A P T E R  1 0
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Understanding the Subtle Art of Animation
Animation is the process by which an object’s size, position, color, or shape changes over

time. In Flash, you have three animation methods, each with their own unique develop-

ment process and strengths: frame by frame, tweening, and Timeline Effects. Before you

start learning about using these methods to infuse your static creations with movement,

you need to grasp some fundamental animation concepts, including frames, keyframes,

and frame rate.

Getting to Know Frames and Keyframes
Any animation, whether the latest Hollywood 3D animated blockbuster, Walt Disney’s

original Fantasia, or your humble Flash creation, contains frames. Each frame contains

one static image that, when displayed in succession with other images in other frames, cre-

ates the illusion of movement. In Flash MX 2004 and Flash MX Pro 2004, frames are dis-

played as small boxes horizontally in the Timeline.

Each frame’s content is displayed as the playhead passes through it, thereby creating

something of a digital “flipbook.”

In Flash, any frame populated by content that you’ve directly manipulated (as opposed

to, for example, placed by Flash in a tweened animation) is represented in the Timeline 

by a small black circle called a keyframe. A keyframe represents a point on the Timeline

where a change occurs in the animation that the animator has directly created or caused.

For the time being, know that any time you want to change your animation in any way

(add content, subtract content, start the motion of an object, and so on), you’ll use a

keyframe.

So what exactly is the difference between content in regular frames and content in

keyframes? It’s pretty simple: Although a keyframe and a frame can have exactly the 

same content, you can directly manipulate

that content only if it resides in a keyframe. 

If it resides within a frame, there is no way,

short of turning the frame into a keyframe

(which is a perfectly functional solution), to

directly manipulate its content.

The small boxes in the Timeline are called cells. Unfortunately, this term is rarely used, so

don’t worry if you don’t see it in the Flash literature. You can convert any cell into a frame, a

keyframe, or an empty keyframe by using the options in the Insert menu. 
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Beyond frames and keyframes, there is a third type of frame you should be aware of.

Somewhere between an ordinary frame and a keyframe, an empty keyframe is essentially a

keyframe that has yet to be “filled” with content. An outline of a small circle represents

an empty keyframe.

Understanding Frame Rate
Frame rate determines the rate at which an animation plays. Represented in frames per

second (fps), an animation’s frame rate is related both to the speed the animation plays at

and its overall quality. Think of it this way: If you have a high frame rate, more frames are

displayed per second, increasing the animation’s quality. The lower your frame rate, the

fewer frames displayed per second, increasing the animation’s choppiness and decreasing

its quality.

You’re probably thinking, that’s all great, but if a higher frame rate means

a better quality animation, then why would anyone ever set a low frame rate?

The most important reason you shouldn’t always set a high frame rate con-

cerns memory and bandwidth. When you set a high frame rate, you force the

user’s computer to display more information per second. A higher frame

rate might cause some slower computers or slower Internet connections to

“choke” on the higher rate of information, causing the animation to hang,

skip, or crash entirely.

To set your animation’s frame rate:

1. Choose Modify ➔ Document or use Cmd/Ctrl+J to open the Document Properties

dialog box (see Figure 10.1). Alternatively, you can double-click the frame-rate indi-

cator at the bottom of the Timeline.

2. Enter a value in the Frame Rate field.

Although 12fps is Flash’s default frame rate, you’re certainly safe if you use a higher frame

rate. However, unless you are absolutely confident your users’ systems can cope with more

information, it’s wise to set a frame rate no higher than 20.

By default, Flash designates the first frame of any animation as an empty keyframe. The

remaining frames in any given layer are little more than placeholders for future empty

keyframes or keyframes (which you need to create).
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How Flash Represents Animation in the Timeline
The Timeline represents the various kinds of animation (and Timeline elements) differ-

ently. As a result, it’s in your best interest to become familiar with each so that when you

get into animating with the Timeline, you won’t be caught off guard by the way an anima-

tion looks.

• A frame-by-frame animation is usually represented by a layer with a series of sequen-

tial keyframes.

• A motion tween is denoted by a keyframe at the beginning and end, between which a

black arrow (representing the actual tween) runs. In addition, a motion tween has a

light-blue background.

• Like a motion tween, a shape tween is denoted by a keyframe at the beginning and

end, between which a black arrow (representing the actual tween) runs. The differ-

ence is that the intervening frames are light green instead of light blue.

• When a keyframe is followed by a dashed line, motion tween is incomplete (usually

the result of the final keyframe being removed or not added).

• When a series of gray frames begins with a keyframe and ends with a hollow rectangle,

all frames after the keyframe have exactly the same content.
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• A frame or keyframe with a lowercase a represents a point in the animation where a

frame action (global function) has been added. (For more information on actions and

ActionScripting, see Parts IV and V of this book.)

• A frame or keyframe with a red flag indicates the presence of a frame label.

Changing the Appearance of Frames in the Timeline
Until now, the only way you could actually change the appearance of a frame was to

change the height of an entire layer (discussed in Chapter 8). The problem with this was

that you weren’t really changing the appearance of the frames themselves, but the layer

Frame labels are extremely useful for identifying and targeting specific frames when you’re

using actions. You can also use them in the development process to add comments or notes

to specific frames. To insert a frame label, select the frame, open the Property Inspector, and

enter the label in the Frame Label field.

Frame Action (Global Function)

In Flash MX 2004 and Flash MX Pro 2004, Actions are now referred to as Global Functions.
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itself. And besides, as you’ve already discovered, there are only three options for layer

height, making it a pretty limited solution.

However, in Flash MX 2004 and Flash MX Pro 2004, you can change the appearance 

of the frames themselves by using the Frame View button, located in the top-right corner of

the Timeline. When clicked, the Frame View button opens a drop-down menu.

When clicked, the Frame View button opens a drop-down menu containing the fol-

lowing options:

• Tiny makes the frames extremely small, allowing more frames to be displayed at any

given time in the Timeline.

• Small changes the size of the frames so that they are between the Tiny option and the

default, Normal.

Unfortunately, the option you choose applies to all layers within the Timeline. You can’t

change the frame appearance for a single layer.

Frame View button
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• Normal is the default frame size.

• Medium changes the size of the frames so that they are slightly larger than the default

Normal size.

• Large increases the Timeline’s frames to their maximum sizes.

• Short reduces the height of the frames in the Timeline.

• The Tinted Frames option, which can be toggled on and off, controls whether or not

frames with content are shaded or not.
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• By selecting Preview in Context, Flash creates a thumbnail of each keyframe’s con-

tents that is a direct proportional reflection of what is on the Stage, including all the

empty space.

• When you choose Preview, you get a thumbnail of each keyframe’s contents that fills

the entire cell (as opposed to being a proportional representation of the entire Stage).

Don’t be fooled: Even though the results of Preview and Preview in Context might be

similar, the difference usually asserts itself in the amount of white space displayed.

Creating a Frame-by-Frame Animation
Way back in the dark ages of animation (before computers), animators had to painstak-

ingly create the individual images in each frame, varying each slightly to get the illusion

of movement.

In Flash, the most basic form of animation, frame-by-frame animation, works the same

way. Essentially, frame-by-frame animation works by creating a unique image in each

frame. Each frame then becomes a keyframe (because it has content that alters the anima-

tion). As the playhead passes through each of the frames, the frame’s content displays, cre-

ating the illusion of change over time. Frame-by-frame animations are great if you want to

exert direct control over the details in your animation.

There is, however, one problem with creating a frame-by-frame animation. Because

each frame needs to be “filled” with content unique from the previous frame, you 

end up creating a lot of static material. Imagine if your movie contained an animation

that was 300-frames long. You would have to create at least 300 static images—a 

laborious undertaking. Granted, using the Library, symbols, and symbol instances to

recycle some of your material could help reduce the workload. However, whichever 

way you look at it, you’d be spending a great deal of time creating art assets for your 

animation.

Displaying extra information in the Timeline, using either Preview or Preview in Context, con-

sumes more processing power, possibly causing your computer to slow down.
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Having said this, let’s look at how you actually create a frame-by-frame animation.

You’ll start with something particularly mundane, a sphere moving across the Stage, to

help you grasp the basics of frame-by-frame animation:

1. Start with a new file (File ➔ New or Cmd/Ctrl+N).

2. When the New Document dialog box opens, select the Flash Document option and

click OK.

3. Choose Insert ➔ New Symbol. When the Create New Symbol dialog box opens, enter

sphere in the Name field, make sure the Graphic radio button is selected, and click OK.

4. When the Symbol Editor opens, draw a sphere about 3 centimeters (1 inch) in diame-

ter. When you’re finished, return to the Stage by clicking the Scene 1 link in the Edit

bar. (See Chapter 7 for how to work with symbols.)

5. Now that you have a sphere in the Library, click the first frame of the Timeline’s sin-

gle layer (which, if you remember, is an empty keyframe by default), open the Library

(Window ➔ Library), and drag the sphere onto the left side of the Stage. Notice that

the first frame automatically becomes a keyframe (denoted by the small black circle).

6. Now that you’ve populated the first keyframe with content, you can create the

remainder of the sequence. Click the second frame in the Timeline (just to the right 

of the keyframe you created) and choose Insert ➔ Timeline ➔ Keyframe (or press F6).

This inserts a second keyframe. You’ll notice that Flash has automatically populated

the keyframe with the content of the previous keyframe. You could keep on adding

successive keyframes, and Flash would continue to populate them with the contents

of the first one.

7. Make sure you have the second keyframe selected. Select the sphere with the Arrow

tool and move it to the right slightly.

If, for some reason, you don’t want the same content in the second frame, just insert a blank

keyframe (Insert ➔ Timeline ➔ Blank Keyframe). To add content to the blank keyframe, select it

and then add something to the Stage. When you do this, the blank keyframe becomes a

keyframe.

Remember, Flash automatically designates the first frame of any layer as an empty keyframe.

As a result, you don’t have to go through the process of inserting a keyframe. However, for

the remainder of the layer, you’ll have to insert each keyframe yourself.
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8. Select the third frame in the Timeline, and insert a new keyframe (Insert ➔ Timeline ➔

Keyframe).

9. Make sure you have the third keyframe selected. From here, select the sphere and

move it slightly to the right.

10. Continue adding successive keyframes and moving the sphere to the right in each one

until it has reached the right side of the Stage. Depending on how much you moved the

sphere each time (the less you moved it, the more keyframes it will take to move it to

the right side of the screen), your Timeline should be filled with a number of keyframes.

Congratulations, you’ve created your first frame-by-frame animation. To test it, you

can do any of the following:

• Drag the playhead through the Timeline to view the animation.

• Choose Control ➔ Play or hit Return/Enter.

• Choose Control ➔ Test Scene or Control ➔ Test Movie (which opens a new window

where the animation will continue to loop).

Working with the Onion Skinning Option
When you were creating a frame-by-frame animation in the previous section, you moved

the sphere in each successive keyframe without having a real reference as to its position 

in the preceding frame. This probably proved to be a little frustrating because, without a

way to get the sphere exactly in line with the one in the previous frame, your animation

looked a little jumpy. Granted, you could simply click the previous frame, check the 

position of the sphere, and then click back and adjust the position of the next one. How-

ever, this process is a little time consuming and frustrating. This is where onion skinning

comes in.

Onion skinning lets you see the contents of frames preceding and following the cur-

rently selected frame. The concept comes from the traditional pen-and-paper animation

technique of using tracing paper to view a sequence of animation frames. With onion

skinning, you can do away with all the guesswork inherent in flipping back and forth to

see the contents of previous frames and smoothly animate a moving object.
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You have several options when using onion skinning:

Turning onion skinning on To turn onion skinning on, click the Onion Skin button

located at the bottom of the Timeline. By doing this, two things happen: First, the Onion

Skin marker is displayed in the Timeline header. The Onion Skin marker displays the

range of frames included in the onion skinning. To increase, decrease, or change the num-

ber of frames included, click one of the handles on either side of the Onion Skin marker

and drag it accordingly.

Second, the frames’ content within the Onion Skin marker displays as partially transpar-

ent. In addition, the contents of the currently selected frame display normally.

Turning onion skinning outlines on By clicking the Onion Skin Outlines button , which

is located at the bottom of the Timeline, you can display the content of multiple frames as

outlines (instead of transparent). Note that the currently selected frame appears normally

when Onion Skin Outlines is activated.

The particular layer’s outline color determines the color of the onion skin outlines.

If you’ve got any locked layers in your animation, they won’t be displayed when you have

onion skinning turned on.

Onion Skin markers
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Editing multiple frames When you have onion skinning turned on, you can’t actually edit

the contents of a frame unless you’ve selected it in the Timeline. This can prove a little

frustrating, as you will constantly have to switch to a given frame to edit its content. One

of the great things about onion skinning is the Edit Multiple Frames button.

Located to the right of the Onion Skin Outlines button, the Edit Multiple Frames button

lets you edit the contents of all frames without having to move from frame to frame.

Unlike with simple onion skinning, the Edit Multiple Frames button displays all the con-

tents without any transparency.

Modifying onion markers The Modify Onion Markers drop-down menu is accessible by

clicking the Modify Onion Markers button , which is located to the right of the Edit

Multiple Frames button at the bottom of the Timeline. Each of the options contained in

the menu affect the position of the Onion Skin marker and therefore the frames that are

displayed:

• Always Show Markers displays the Onion Skin markers in the Timeline header

regardless of whether onion skinning is turned on.

• Under normal circumstances, the Onion Skin range is relative to the current frame

pointer and the Onion Skin markers. By selecting Anchor Onion, you lock the Onion

Skin markers to their current position in the Timeline header.

• Onion 2 displays two frames on either side of the currently selected frame.

• Onion 5 displays five frames on either side of the currently selected frame.

• Onion All displays all the frames on either side of the currently selected frame.

Understanding Tweening
Now that you’ve created a frame-by-frame animation, let’s take the next step and look

at a far more efficient and less time-consuming way to create an animation: tweening.

Essentially, tweening is the process by which you define a starting point/form and end-

ing point/form for an object and then tell Flash to fill in all the in-between frames, hence

the name.

Two types of tweening are available depending on what you want your animation to

do. The first, motion tweening, is covered next. The second, shape tweening, is covered in

the section “Creating a Shape-Tweened Animation” later in this chapter. After looking at

motion- and shape-tweened animation, you’ll see how you create a motion-tweened ani-

mation that follows a path.
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Creating a Motion-Tweened Animation
In the previous section, you learned how to create a frame-by-frame animation by filling

each frame with content. All in all, the process is pretty clunky. This is where motion tween-

ing comes in. Motion tweening is a quantum leap beyond frame-by-frame animation—no

more working with frame after frame, painstakingly crafting each image in your animation

so it is just right. With motion tweening, you merely create the first and last keyframes in

your animation; from there, Flash completes the in-between frames. And because Flash has

to save the contents of only the first and last keyframes (along with numerical values con-

cerning how the object changes), tweened animations generally result in smaller file sizes

than frame-by-frame animations.

Although you use tweening primarily for animating motion, you can also animate size,

color, and orientation. In short, any transformation that can be applied to an object can

be animated with tweening.

In this section, you’re going to create the same sort of animation you created using the

frame-by-frame technique (a square moving across the Stage), but you’ll use tweening

instead:

1. Start with a new file (File ➔ New or Cmd/Ctrl+N).

2. When the New File dialog box opens, choose the Flash Document options and click OK.

3. Choose Insert ➔ New Symbol. When the Create New Symbol dialog box opens, enter

square in the Name field, make sure the Graphic radio button is selected, and click OK.

4. When the Symbol Editor opens, draw a square about 3 centimeters (about 1 inch) in

diameter. When you’re finished, return to the Stage by clicking the link in the Edit bar.

5. Now that you have a square ready and waiting in the Library, click the first frame of

the Timeline’s single layer, open the Library (Window ➔ Library), and drag the square

onto the left side of the Stage. Notice that the default blank keyframe automatically

becomes a keyframe (denoted by the small black circle).

6. Now that you’ve created the first keyframe in the animation, you can create the last

one. Click frame 25, and insert a keyframe by choosing Insert ➔ Timeline ➔ Keyframe.

At this point, your Timeline should look like this:

You can use motion tweening on text as well as groups of objects.
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Much as in the case of frame-by-frame animation, Flash populated the second

keyframe you created with the content of the first. As a result, you are going to want to

move the square in the last keyframe to the location on the Stage where you want it to be

at the end of the animation:

1. Select the final keyframe.

2. Using the Arrow Tool, click and drag the square to the right side of the Stage. By

doing this, you tell Flash that in the first keyframe the square is at the left side of the

Stage, and in the last keyframe it’s in the right side of the Stage.

3. Now comes the tweening. Select the first keyframe.

4. Choose Insert ➔ Timeline ➔ Create Motion Tween. Alternatively, you can select the

first keyframe, open the Property Inspector (Window ➔ Properties), and select

Motion from the Tween drop-down menu.

5. Flash fills all the in-between frames, thereby creating the animation. You’ll also notice

that the Timeline itself changes. The change in the frames’ colors as well as an addi-

tion of an arrow indicate the presence of a tween.

Congratulations, you’ve created your first tweened animation. To test it, do one of 

the following:

• Drag the playhead through the Timeline to view the animation.

• Choose Control ➔ Play or hit Return/Enter.

• Select Control ➔ Test Scene/Test Movie to open a new window in which the anima-

tion will continue to loop.

Even though the motion tween that you’ve just created is quite simple, don’t think that

motion tweening creates only simple animations. You can create some amazingly complex

and varied animation with tweening. As an experiment, take the animation you just cre-

ated, insert a keyframe in the middle, and alter the square’s location. When you play the

The frames between the two keyframes are just that: frames. They really don’t do much

except contain the content that is automatically generated by Flash. If you want them to

become more, you must insert a keyframe.
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animation, Flash moves the square to the new location defined in the keyframe that you

just added and then to the position that you set in the final keyframe.

You also don’t have to merely move your square across the Stage. Try increasing the

object’s size in the final keyframe using the Transform panel (Window ➔ Design Panels ➔

Transform) or the Free Transform tool. When played, the square slowly grows until it

reaches the defined size in the final keyframe.

You can also change the visual properties of a tweened symbol using the Property

Inspector—something you’ll learn how to do in the section “Animating a Symbol

Instance’s Visual Properties with the Property Inspector” later in this chapter.

Editing a Tweened Animation
Although you can create a motion-tweened animation with Flash’s drop-down menu, you

can’t do much to edit the animation’s characteristics this way. Instead, you use the Prop-

erty Inspector (Window ➔ Properties or Cmd/Ctrl+F3) to manipulate all manner of the

tweened animation’s characteristics, including those specific to motion tweening.

Some of the options in the Property Inspector apply to other types of tweening, such as

shape and motion-path tweening. You’ll

get to them in the sections “Creating a

Shape-Tweening Animation” and “Creat-

ing an Animation That Follows a Path,”

respectively; for now, let’s look at the

motion-tweening options.

Easing a Motion Tween Animation

You probably noticed that your tweened square traveled at a constant rate across the

Stage. If you want, you can use the Property Inspector to ease the object in or out of the

animation. In other words, it starts off more slowly, gaining speed through the process of

the animation. On the other hand, if you ease the object out of the animation, it slows

down near the end.

To ease your motion tween, follow these steps:

1. Select the first frame in the motion tween.

2. Open the Property Inspector by choosing Window ➔ Properties or by using

Cmd/Ctrl+F3.

3. Enter a value into the Ease field. A positive number eases the object out of the anima-

tion, and a negative eases it in. A higher value (either negative or positive) increases

the effect. Alternatively, you can use the Ease slider to adjust the value.

You can enter values from –100 to 100 in the Easing field.
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Rotating a Motion-Tweened Object

Follow these steps to get an object to rotate through the tweening:

1. Select the first frame in the motion tween.

2. Open the Property Inspector by choosing Window ➔ Properties or by using the 

shortcut Cmd/Ctrl+F3.

3. Choose one of the options from the Rotate drop-down menu.

None Applies no rotation to the object.

Auto Rotates the object once in the direction that requires the least amount of 

movement.

CW Rotates the object clockwise. You define the number of rotations by entering 

a value into the Times field (which is to the right of the Rotate drop-down menu).

CCW Rotates the object counterclockwise. You define the number of rotations 

by entering a value into the Times field (which is to the right of the Rotate drop-

down menu).

Creating a Motion-Tweened Animation That Follows a Path
When it comes to motion tweening, you’ve explored how to move an object along a

straight line. Granted, you can vary the course of the object’s motion by adding more

keyframes to the animation (as discussed earlier), creating a zigzag pattern. However,

what if you want to make an object move along a circle? Motion paths let you move objects

along a specific path (see Figure 10.2).

You learned how to create motion guide layers in Chapter 8; in this section, you’ll take

what you learned in Chapter 8 and combine it with what you’ve learned about motion tween-

ing in this chapter to craft an animation that has an object traveling along a complex path.

To create an animation that follows a path, use these steps:

1. Create a simple motion-tweened animation with two keyframes, one at the beginning

and one at the end. (If you want, you can use the square animation you created earlier

in this chapter.) To learn how to create a simple motion tween, see the section “Creat-

ing a Motion-Tweened Animation” earlier in this chapter.

2. Select the layer with the tweened animation and choose Insert ➔ Timeline ➔ Motion

Guide. Alternatively, you can Ctrl+click (Mac) or right-click (Win) the layer’s name

and choose Add Motion Guide from the pop-up context menu or click the Add

Motion Guide button in the bottom-left corner of the Timeline. This creates a

motion guide layer just above the layer containing the animation.

232 ■ chapter 10: Animating with the Timeline

Figure 10.2

The motion path 
can take any form

you desire. This one
was drawn with the

Pen tool.

4284c10.qxd  11/18/03  9:44 PM  Page 232

RahulVerma-PC
Highlight

RahulVerma-PC
Highlight



3. Now, with the first frame (the empty keyframe) in the motion guide layer selected,

draw the path you want the object to follow (as illustrated back in Figure 10.2). You

can use any of these tools: Pencil, Oval, Rectangle, Brush, Pen, or Line.

4. Now it’s now time to attach your object to the motion path that you’ve created. Select

the first keyframe of your tweened animation, choose Window ➔ Properties, and

make sure the Snap check box is selected so your object’s registration point will snap

to the motion path.

5. Click and drag the object so the registration point snaps onto the beginning of the

path you’ve drawn.

If the registration point doesn’t appear when you
click the object, release it, click the central portion 
of the object (represented by a set of crosshairs),
hold your mouse button down for a few seconds,
and then drag it to the beginning of the path.

6. Now, click the final keyframe in the animation, and click and drag the object so the

registration point snaps onto the end of the path you’ve drawn.

7. If you want the object to point in the direction of the path that it’s moving along,

make sure the Orient to Path check box is selected in the Property Inspector.

Orient to Path check box

Snap check box
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8. From here, test your animation by hitting Return/Enter, choosing Control ➔ Play, or

selecting Control ➔ Test Scene/Test Movie.

Creating a Shape-Tweened Animation
While motion tweening moves an object from one point of the Stage to another (or

changes its characteristics, such as size or orientation), shape tweening morphs an object

from one shape to another. You can create some decidedly interesting effects by using

shape tweening.

To create a shape tween:

1. Create a new document.

2. Select the first frame, which is a blank keyframe by default.

3. Use the drawing tools to create the image you want to start with. Notice that the first

frame automatically becomes a filled keyframe (denoted by the small black circle).

4. Click the frame where you want the shape tween to end, and insert a keyframe. As

usual, Flash populates the last keyframe with the first keyframe’s contents.

5. Manipulate the object (using one of the various transform tools) so it looks like what

you want for the final shape tween. (Alternatively, delete the image and create an

entirely new one.)

6. Now select the first frame and open the Property Inspector (Window ➔ Properties).

7. Choose Shape from the Tweening drop-down menu.

If you place the last keyframe’s shape in another location, Flash automatically motion tweens

the animation as well. Not only will your object “morph,” but it will do so as it moves from

one location to another on the Stage.

One of the most fundamental things you need to remember about shape tweening is that it

works only on shapes drawn on the Stage. You can’t shape tween symbol instances, bitmaps,

text, or groups of objects. You must break apart these elements (Modify ➔ Break Apart) before

you can shape tween them.

You can “unlink” a layer from a motion guide by selecting the layer and either clicking and

dragging the layer above the motion guide layer in the Timeline or choosing Modify ➔ Time-

line ➔ Layer Properties ➔ Normal.
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8. From here, you can set the shape tween’s characteristics:

• Enter a value into the Ease field to ease the tween in or out. Remember, a positive

number makes the tween faster at the beginning, and a negative number makes it

faster at the end. Alternatively, use the Ease slider to adjust the value.

• Choose a blend option from the Blend drop-down menu. Choosing Distributive

creates an animation in which the edges of the intermediate shapes are smoother.

Alternatively, choosing Angular creates an animation in which straight edges are

preserved in the intervening frames.

9. When you’ve finished, test your animation by moving the playhead, hitting

Return/Enter, and selecting Control ➔ Play or choosing Control ➔ Test Scene/

Test Movie.

Animating a Mask
As explained in Chapter 8, mask layers create a hole through which the contents of one

layer are visible. The cool thing about masks is that you can animate them to create any

number of interesting effects—from the view through a telescope to the view through a

keyhole. In this section, you’ll look at how to create a spotlight effect that moves across 

the Stage, revealing a stationary object as it passes over it:

1. First, create a new document.

2. Choose File ➔ Import ➔ Import to Stage. When the Import dialog box opens, navigate

to the Chapter 10 directory on this book’s companion CD, choose All Files from the

Import dialog box’s Files of Type drop-down menu, select the alien.swf file, and

click OK.

3. Now click frame 25 and choose Insert ➔ Timeline ➔ Frame. This populates the frames

from 2 to 25 with the content of the first keyframe.

4. From here, you’re going to create the object that will serve as the mask. Select Insert ➔

New Symbol. When the Create New Symbol dialog box opens, make sure the Graphic

radio button is checked and enter circle into the Name field.

Blend drop-down menu
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5. When the Symbol Editor opens, draw a single sphere of about 3 centimeters (1 inch)

in diameter. Remember, the circle needs to be filled for the mask to work. Beyond

that, the color of the fill makes no difference whatsoever.

6. Exit the Symbol Editor by clicking the Scene 1 link in the Edit bar.

7. Now create a new layer by clicking the Insert Layer button in the Timeline. Alterna-

tively, you can Ctrl+click (Mac) or right-click (Win) on the Timeline’s existing layer,

and choose Insert Layer from the pop-up context menu. You can also choose Insert ➔

Timeline ➔ Layer. This layer will ultimately be converted into the mask layer.

8. Select the first blank keyframe in the new layer and drag the Circle symbol from the

Library (Window ➔ Library) to the left part of the Stage.

9. Click frame 25 (in the newly created layer) and choose Insert ➔ Timeline ➔ Keyframe.

With the last keyframe selected (the one you just created), click and drag the circle to

the right side of the Stage.

10. Select the first keyframe and choose Insert ➔ Timeline ➔ Create Motion Tween. This

animates the sphere so that it moves across the Stage and passes over the flying saucer

image that you imported earlier.

11. Now it’s time to turn the tweened circle into a mask. Ctrl+click (Mac) or right-click

(Win) the layer with the circle symbol, and choose Mask from the pop-up context

menu. By doing this, you turn the layer with the circle into a mask layer. Notice that

the appearance of both layers changes to reflect the relationship. Also, this process

locks both the mask and masked layers. They must remain locked for the animation

to work.

12. From here, test your animation by hitting Return/Enter and choosing Control ➔ Play

or selecting Control ➔ Test Scene/Test Movie.

Don’t worry if the flying saucer disappears from the Stage; this is supposed to happen. If you

want to view both the flying saucer image and the circle symbol, unlock all the layers.
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Extending a Still Image Through Time
So far, you’ve explored how to do all sorts of cool animations with the Timeline. There is,

however, an additional animation trick that, although straightforward, is incredibly use-

ful. Specifically, you can integrate an image into your Flash movie that occupies a span of

time (a series of frames) but doesn’t actually move. Here’s how you do it:

1. Create a new document.

2. Select the first blank keyframe in the single layer.

3. Place the desired image onto the Stage.

4. Click the last keyframe that you would like the image to be visible on.

5. Choose Insert ➔ Timeline ➔ Frame or use the shortcut F5. Alternatively, you can

Ctrl+click (Mac) or right-click (Win) and choose Insert Frame from the pop-up 

context menu.

6. Notice that all the intermediate frames are gray, and a small outline of a rectangle is

placed in the final frame. This means that the content from the first keyframe has

been carried over to all the frames.

Animating a Symbol Instance’s Visual Properties
with the Property Inspector
One of the great things about tweening is that you are not limited to position, size, and

shape. You can also tween more complicated changes to an object’s appearance. You can

animate a fade-in/fade-out or color change by taking what you’ve learned about tweening

thus far and combining it with the tools in the Property Inspector (Window ➔ Properties).

Back in Chapter 6, you manipulated a symbol’s visual properties with the Property Inspec-

tor, so its options should be familiar to you. In the following sections, you’ll now learn

how to animate changes in an object’s transparency, brightness, and tint.

Animating a Symbol’s Transparency
By animating an object’s Alpha effect (or transparency), you can create the illusion of a

fade-in/fade-out:

1. Create a new document.

2. Create a tweened animation of some sort using symbols.

You can carry out the following processes only on symbols, not on shapes or groups of

shapes created with Flash’s painting and drawing tools directly on the Stage.
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3. Now click the first keyframe in the animation and select the object that you want to

fade in with the Arrow tool.

4. If it isn’t open already, open the Property Inspector by choosing Window ➔ Properties.

5. Choose Alpha from the Color drop-down menu.

6. Enter 0 into the Alpha Value field. By doing this, you are making the object in the first

keyframe transparent.

7. Click the last keyframe in the animation, and select the object that you’re working on

with the Arrow tool.

8. With the Property Inspector open and Alpha selected from the Color drop-down

menu, enter 100 into the Alpha Value field. This makes the object opaque (solid) in

the final keyframe.

9. Now, test your animation by hitting Return/Enter and going to Control ➔ Play, or

select Control ➔ Test Scene/Test Movie. Your object will now fade in.

Animating an Object’s Brightness
Animating an object’s brightness is almost identical to the process of animating an object’s

transparency:

1. Create a new document.

2. Create a tweened animation using a symbol.

3. Now click the first keyframe in the animation and select the object whose brightness

you want to change.

4. If it isn’t open already, open the Property Inspector by choosing Window ➔ Properties.

5. Choose Brightness from the Color drop-down menu.

6. Enter a value into the Brightness Value field (or use the Brightness slider).

7. Click the last keyframe in the animation, and select the object that you’re working with.

8. With the Property Inspector open, enter a different value into the Brightness Value field.

9. Now test your animation by hitting Return/Enter and choosing Control ➔ Play, or

selecting Control ➔ Test Scene/Test Movie.

Because you can’t simulate the same sort of brightness experienced in the real world, altering

the brightness of an object actually does more to change the intensity of its color.

To have an item fade out, do the opposite. Set the Alpha Value in the first keyframe to 100

and that of the last keyframe to 0.
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Animating Color Change
Like the previous two procedures, animating a color change is just a matter of using a dif-

ferent area of the Property Inspector:

1. Create a new document.

2. Create a tweened animation of some sort using a symbol.

3. Now click the first keyframe in the animation and select the object whose color you

want to change.

4. If it isn’t open already, open the Property Inspector by choosing Window ➔ Properties.

5. Choose Tint from the Color drop-down menu.

6. From here, click the Tint color swatch to open up the Color Picker. From here,

choose one of the colors. Alternatively, you can mix a custom RGB color by inputting

values into the R, G, and B fields.

7. Click the last keyframe in the animation, and select the object that you’re working with.

8. With the Property Inspector open, choose another color.

9. Now test your animation by hitting Return/Enter and going to Control ➔ Play, or

selecting Control ➔ Test Scene/Test Movie. Your object will change from the color set

in the first keyframe to the color set in the last keyframe.

Using Timeline Effects
So far, you’ve explored two ways you can add animation to your Flash movie: tweening

and frame-by-frame animation. These two methods have been around since the dawn of

Flash, and are very tried and true. However, in Flash MX 2004 and Flash MX Pro 2004,

Macromedia has introduced a third way of adding animation to your movie: Timeline

Effects.

To be completely honest, Timeline Effects are not really a new kind of animation; they

are simply a new way of created tweened animation. Timeline Effects were originally 

created in recognition of the fact that tweening, though easily learned, can take a fair

amount of time. Look at it this way: If your movie is fairly animation intense, you can

spend a lot of time repeating the tweening process over and over. This is where Timeline

Effects come in. They are basically a series of preset (though very editable) animations

that you can apply to just about any element in your movie. In total, there are eight

Timeline Effects: Blur, Copy To Grid, Distributed Duplicate, Drop Shadow, Expand,

Explode, Transform, and Transition.
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In this section, you’ll explore how to apply a Timeline Effect to an Object, edit a Time-

line Effect, and remove a Timeline Effect from an object. From there, you’ll explore each

of the Timeline Effects available in Flash MX 2004 and Flash MX Pro 2004.

Applying a Timeline Effect
The Process by which you apply a Timeline Effect to an object is actually quite easy. All

you need to do is follow these steps:

1. Select the object you want to apply the Timeline Effect to.

2. From here, you have two options:

• Choose Insert ➔ Timeline Effects and select one of the effects in the list.

• Ctrl+click (Mac) or right-click (Win) the object that you’re attaching the Time-

line Effect to. When the context menu opens, select Timeline Effects and choose

an effect from the list.

3. Based on the specific Timeline Effect that you selected, a different dialog box will

open, allowing you to edit the properties of the effect.

For the specifics on each Timeline Effect, see the section “Working with Flash’s Standard

Timeline Effects” later in this chapter.

Timeline Effects can be applied to text, bitmaps, graphic symbols, button symbols, shapes,

grouped objects, and Movie Clips.

You might notice that, when you apply a Timeline Effect, a new folder (complete with any

number of different symbols) is added to your Library. You also might notice that, if it isn’t

already, the symbol you attached the Timeline Effect to is converted into a Movie Clip. Don’t

worry, this is supposed to happen. When you add a Timeline Effect, Flash generates the addi-

tional visual assets that make the effect possible and adds them to your Library. While you

can actually go into these folders and manually edit the effect’s assets (altering how the

effect appears in your movie), I would not advise it.

Not all Timeline Effects are animation-specific. Drop Shadow, Copy to Grid, and Distributed

Duplicate don’t result in any kind of motion; they simply change the appearance of the

selected symbol. Timeline Effects that don’t produce an animation are included here so that

all Timeline Effects are covered together.
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Editing a Timeline Effect
Once you’ve added a Timeline Effect, it’s just as easy to go back and edit it. Here’s how:

1. Select the object you attached the Timeline Effect to that you want to edit.

2. From here, you have a few choices:

• If it isn’t already, open the Property Inspector (Window ➔ Properties) and click

the Edit button. The specific Timeline Effects dialog box will open, allowing you

to make any changes you want.

• Ctrl+click (Mac) or right-click (Win) the object to which you attached the Time-

line Effect, and choose Timeline Effects ➔ Edit Effect from the pop-up context

menu. When the effect-specific dialog box opens, make any changes you want.

• Choose Modify ➔ Timeline Effects ➔ Edit Effect. When the Timeline Effects dialog

box opens, you can change the effect’s properties as you see fit.

Removing a Timeline Effect
What if you decide that you would like to remove a Timeline Effect that you had applied

to an object within your movie? It’s easy as pie; just follow these steps:

1. Select the object you attached the Timeline Effect to that you would like to remove.

2. From here, you have a couple of options:

• Ctrl+click (Mac) or right-click (Win) the object to which you attached the 

Timeline Effect and choose Timeline Effects ➔ Remove Effect from the pop-up

context menu.

• Choose Modify ➔ Timeline Effects ➔ Remove Effect.

Working with Flash’s Standard Timeline Effects
As mentioned previously, Flash MX 2004 and Flash MX Pro 2004 ship with eight Time-

line Effects (not all of which create animation). In this section, you’ll explore the intrica-

cies of each.

One of the coolest things about this new generation of Flash is the JavaScript Application

Programming Interface (JSAPI), which allows users to access and extend Flash’s program

architecture. The JSAPI allows the creation of new behaviors, components, interface ele-

ments, and most importantly to this section, Timeline Effects. As a result, as Flash MX 2004

and Flash MX Pro 2004 gain steam, you’ll probably see new Timeline Effects become avail-

able (either distributed freely or as purchasable add-ons).
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Copy To Grid

As with a number of the Timeline Effects, Copy To Grid really doesn’t have anything to do

with animation. Instead, when applied, it takes the object to which you applied the effect

and creates a repeating pattern (laid out along a grid). To use the Copy To Grid Timeline

Effect, just follow these steps:

1. With the Arrow tool, select the object to which you want to apply the Copy To 

Grid effect.

2. From here, you have a few options:

• Choose Insert ➔ Timeline Effects ➔ Assistants ➔ Copy To Grid.

• Ctrl+click (Mac) or right-click (Win) the object you’re attaching the Timeline

Effect to. When the context menu opens, select Timeline Effects ➔ Assistants ➔

Copy To Grid.

3. When the Copy To Grid dialog box opens (see Figure 10.3), enter the number of rows

of objects in the Rows field (the default is 2).

4. Enter the number of columns that you want in the grid in Columns field (the

default is 2).

5. Now you need to define the distance between the objects in the grid. First, enter a

value (in pixels) in the Rows field of the Grid Spacing section to set the distance

between the rows in the grid.

Figure 10.3

The Copy To Grid
dialog box
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6. Enter a value (in pixels) in the Columns field of the Grid Spacing section to determine

the distance between the columns in the grid.

7. To preview how the Timeline Effect will look, click the Update button in the upper-

right corner of the Copy To Grid dialog box.

8. When you’re finished, click OK.

Distributed Duplicate

Like the Copy To Grid Timeline Effect, the Distributed Duplicate effect really isn’t geared

toward creating an animation (though you can create an animation with it if you want).

Instead, the effect takes the object to which it was applied and creates a number of copies

(or clones) whose distance, angle, rotation, scaling, color, and opacity from the original

can be fully controlled.

To use the Distributed Duplicate Timeline Effect, follow these steps:

1. With the Arrow tool, select the object to which you want to apply the Distributed

Duplicate Timeline effect.

2. From here, you have a few options:

• Choose Insert ➔ Timeline Effects ➔ Assistants ➔ Distributed Duplicate.

• Ctrl+click (Mac) or right-click (Win) the object you’re attaching the Timeline

Effect to. When the context menu opens, select Timeline Effects ➔ Assistants ➔

Distributed Duplicate.

3. When the Distributed Duplicate dialog box opens (see Figure 10.4), enter the number

of clones you want to create in the Number Of Copies field (the default is 5).

Figure 10.4

The Distributed
Duplicate dialog box
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4. Now you need to set how far the successive copies are offset from the copy before

them. To do this, enter a value (in pixels) in the X field to determine the distance

along the vertical axis.

5. Enter a value (in pixels) into the Y field to set the amount of distance along the hori-

zontal axis.

6. Enter a value (in degrees) that you want each successive clone to rotate in the Offset

Rotation field. A positive number rotates the object clockwise, while a negative num-

ber rotates it counterclockwise.

7. If you want the effect to be animated, enter a value in the Offset Start Frame field. The

value represents the delay in frames between the drawing of each successive duplicate.

If you enter a value of 0, the effect will not animate.

8. From here, you need to set how (and if) the successive clones are scaled. First, select

one of the options—Exponential Scaling or Linear Scaling—from the Scaling drop-

down menu.

9. Now enter a value (in percent) in the Scale field. The lower the number, the smaller

each object will be each successive step. If you want to control both the X and Y scale

values independently, click the Padlock icon to the right of the Scale field and enter a

value into the X and Y fields when they appear.

10. If you want the object to change color from its first step to its last, select the Change

Color check box. Then, click the Final Color swatch and choose one of the colors

from the Color Picker.

11. If you want the transparency of the object to change between its first step and 

its last, enter a value (between 0 and 100) in the Final Alpha field. Alternatively, 

you can use the slider below the Final Alpha field to adjust the alpha value of the

final step.

12. To preview how the Timeline Effect will look, click the Update button in the upper-

right corner of the Distributed Duplicate dialog box.

13. When you’re finished, click OK.

Blur

As its name suggests, the blur effect creates the appearance that an object is out of focus.

Let’s take a look at how the Blur effect works:

1. With the Arrow tool, select the object that you want to apply the Blur effect to.
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2. From here, you have a few options:

• Choose Insert ➔ Timeline Effects ➔ Effects ➔ Blur.

• Ctrl+click (Mac) or right-click (Win) the object you’re attaching the Timeline

Effect to. When the context menu opens, select Timeline Effects ➔ Effects ➔ Blur.

3. When the Blur dialog box opens (see Figure 10.5), enter the number of frames that

you would like the blur to last in the Effect Duration field.

4. Set the visual quality of the blur effect by entering a value in the Resolution field. A

higher resolution means a higher quality blur—but it also means that your final Flash

movie will have a larger file size. Likewise, a lower resolution results in low visual

quality, but a smaller file size.

5. To set the degree to which the blur increases outward beyond the bounds of the origi-

nal object, enter a value in the Scale field. The higher the number, the more the blur

will expand.

6. From here, you need to determine which direction the blur expands. If you want it to

expand horizontally, click the Allow Horizontal Blur check box. If you want the blur

to expand vertically, click the Allow Vertical Blur check box.

7. If you want more control of which direction the blur expands, click one of the Direc-

tion of Movement arrows (the central arrow expands the blur in all directions).

8. To preview how the Timeline Effect will look, click the Update button in the upper-

right corner of the Blur dialog box.

9. When you’re finished, click OK.

Figure 10.5

The Blur dialog box
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Drop Shadow

Like many of the Timeline Effects, Drop Shadow doesn’t actually create an animation.

However, as drop shadows have become fairly ubiquitous in the world of interactive

media, it’s a handy effect to have in your quiver. To use the Drop Shadow Timeline Effect,

follow these steps:

1. With the Arrow tool, select the object that you want to apply the Drop Shadow effect to.

2. From here, you have a few options:

• Choose Insert ➔ Timeline Effects ➔ Effects ➔ Drop Shadow.

• Ctrl+click (Mac) or right-click (Win) the object you’re attaching the Timeline

Effect to. When the context menu opens, select Timeline Effects ➔ Effects ➔

Drop Shadow.

3. When the Drop Shadow dialog box opens (see Figure 10.6), click the Color swatch

and choose a color from the Color Picker to set the color of the shadow.

4. Set the transparency of the shadow by entering a value (in percent) in the Alpha

Transparency field. Alternatively, you can adjust the Alpha Transparency slider.

5. Set the distance that the shadow is offset from the actual object by entering a value (in

pixels) in the X field (which sets the horizontal distance) and the Y field (which sets

the vertical distance).

6. To preview how the Timeline Effect will look, click the Update button in the upper-

right corner of the Drop Shadow dialog box.

7. When you’re finished, click OK.

Figure 10.6

The Drop Shadow
dialog box
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Expand

The Expand Timeline Effect lets you take an object and either blow it up (expand) or

shrink it down (squeeze) based on a series of different properties. The Expand Timeline

Effect can also be used to scatter a group of objects. To apply the Expand Timeline Effect

to an object, follow these steps:

1. With the Arrow tool, select the object that you want to apply the Expand effect to.

2. From here, you have a few options:

• Choose Insert ➔ Timeline Effects ➔ Effects ➔ Expand.

• Ctrl+click (Mac) or right-click (Win) the object you’re attaching the Timeline

Effect to. When the context menu appears, select Timeline Effects ➔ Effects ➔

Expand.

3. When the Expand dialog box opens (Figure 10.7), enter the number of frames you

want the animation to take into the Effect Duration field.

4. If you want the object to increase in size, click the Expand radio button. If you want

the object to shrink, click the Squeeze radio button. If you want the object to both

expand and shrink, click the Both radio button.

Figure 10.7

The Expand 
dialog box

How can the object both expand and shrink? Technically, it can’t. Instead, when you select

the Both radio button, Flash splits the number of frames you designated into two animations:

one of the object expanding and one of the object shrinking. Once applied, the animation

expands and then shrinks in size.
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5. Click one of the Direction Of Movement arrows to determine which direction the

object will expand or contract.

6. If you are working with a group of objects (as opposed to just one), enter a value in

the Shift Group Center By X field to shift the center of the group a certain number of

pixels along the X axis from where it currently is.

7. If you are working with a group of objects, enter a value in the Shift Group By Y field

to shift the center of the group to a position a certain number of pixels along the Y

axis from its current position.

8. If you are working with a group of objects, enter a value in the Fragment Offset field

to determine the distance from each object’s original position that they travel away

from the center of the group.

9. Now you need to set how much the object expands or contracts. First, enter a value

(in pixels) in the Change Fragment Size By Height field to set the object’s vertical size

change.

10. Next enter a value (in pixels) in the Change Fragment Size By Width field to set the

object’s horizontal size change.

11. To preview how the Timeline Effect will look, click the Update button in the upper-

right corner of the Expand dialog box.

12. When you’re finished, click OK.

Explode

As its name suggests, the Explode Timeline Effect lets you shove a stick of digital dynamite

under your object, blow it up, and then control how the pieces react afterward. While

Explode certainly isn’t as complex as some of the exploding-particle effects you see in

many upper-level 3D modeling programs, it’s still quite fun to play with.

To use the Explode Timeline Effects, follow these steps:

1. With the Arrow tool, select the object to which you want to apply the Explode effect.

2. From here, you have a few options:

• Choose Insert ➔ Timeline Effects ➔ Effects ➔ Explode.

• Ctrl+click (Mac) or right-click (Win) the object you’re attaching the Timeline

Effect to. When the context menu opens, select Timeline Effects ➔ Effects ➔ Explode.

3. When the Explode dialog box opens (see Figure 10.8), enter the number of frames

you want the explosion to last in the Effect Duration field.

If you are working with a group of objects, Flash automatically determines the center of the group.
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4. Click one of the Direction Of Explosion arrows to determine which direction the pieces

of the exploded object will fly.

5. Now you need to define the characteristics of the arc of the exploding pieces. First,

enter a value (in pixels) in the Arc Size X field to set the horizontal distance of the

arc, then enter a value (in pixels) in the Arc Size Y field to set the height.

6. Enter a value (in degrees) into the Rotate Fragments By field to determine how much

the pieces will rotate as they fly away. A positive number rotates the pieces clockwise,

while a negative number rotates them counterclockwise.

7. Now you need to set the size change (if any) of the pieces as they fly away. First, enter

a value (in pixels) in the Change Fragments Size By X field to expand the size of the

pieces horizontally. A positive number expands the pieces, while a negative number

makes them smaller.

8. Enter a value (in pixels) in the Change Fragments Size By Y field to increase (or

decrease) the size of the pieces vertically.

9. Enter a value (from 0–100) in the Final Alpha field to set the transparency of the

pieces at the end of their arc. Alternatively, you can use the Final Alpha slider.

10. To preview how the Timeline Effect will look, click the Update button in the upper-

right corner of the Explode dialog box.

11. When you’re finished, click OK.

Figure 10.8

The Explode 
dialog box
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Transform

The Transform Timeline Effect is easily one of the most powerful of the Timeline Effects.

With it, you can move, scale, fade, rotate, ease, and change the color of an object.  Basically,

the Transform effect lets you carry out almost all the things you could do if you were using

tweening—except you can do it all from a single dialog box.

To work with the Transform effect, just follow these steps:

1. With the Arrow tool, select the object to which you want to apply the Transform effect.

2. From here, you have a few options:

• Choose Insert ➔ Timeline Effects ➔ Transform/Transition ➔ Transform.

• Ctrl+click (Mac) or right-click (Win) the object you’re attaching the Timeline

Effect to. When the context menu opens, select Timeline Effects ➔ Trans-

form/Transition ➔ Transform.

3. When the Transform dialog box opens (see Figure 10.9), enter the number of frames

that you want the Transform to last in the Effect Duration field.

4. If you want the object to move to a specific point on the Stage, select Move to Posi-

tion from the drop-down menu at the top of the dialog box, and then enter the exact

coordinates in the X and Y fields.

Figure 10.9

The Transform 
dialog box

You can use the Info panel (Window ➔ Design Panels ➔ Info) to get the exact X/Y coordinates

of any position on your Stage.
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5. If you want to change the object’s position by a certain number of pixels (as opposed

to moving it to a specific X/Y coordinate on the Stage), select Change Position By

from the drop-down menu at the top of the dialog box and enter (in pixels) the hori-

zontal distance in the X field and the vertical distance in the Y field.

6. If you want the object to expand or contract, enter a value (in percent) in the Scale

field. If you want to control the horizontal and vertical scale independently, click the

Padlock icon to the left of the Scale field. Then, when the X and Y fields are dis-

played, you can enter different values in each.

7. If you want the object to rotate, you have two options:

• Enter a value (in degrees) into the Rotate field.

• Enter a value into the Spin field. Click the clockwise button or the counter-

clockwise button to determine which direction the object spins.

8. If you want the object to change color during the transform, check the Change Color

check box. Then click the color swatch and select the final color of the object from the

Color Picker.

9. Enter a value (0–100) into the Final Alpha field. This determines the transparency of

the object at the end of its transform. Alternatively, you can use the Final Alpha slider.

10. Enter a value into the Ease field (between –100 and 100). This value controls whether

the transform starts out quickly and slows near the end or starts out slowly and gains

speed. Alternatively, use the Ease slider.

11. To preview how the Timeline Effect will look, click the Update button in the upper-

right corner of the Transform dialog box.

12. When you’re finished, click OK.

Transition

The Transition Timeline Effect lets you apply a wipe or dissolve to a selected object; let’s

take a look at how:

1. With the Arrow tool, select the object to which you want to apply the Transition effect.

2. From here, you have a few options:

• Choose Insert ➔ Timeline Effects ➔ Transform/Transition ➔ Transition.

• Ctrl+click (Mac) or right-click (Win) the object you’re attaching the Timeline

Effect to. When the context menu openss, select Timeline Effects ➔

Transform/Transition ➔ Transition.

3. When the Transform dialog box opens (see Figure 10.10), enter the number of frames

you want the Transition to last in the Effect Duration field.
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4. Select whether you want the object to Wipe, Dissolve, or Wipe and Dissolve by click-

ing the appropriate check box.

5. From there, you need to determine if the object wipes or fades (depending on your

choice) in or out. To do so, select the appropriate radio button in the Direction sec-

tion of the Transition dialog box.

6. Now, click on one of the Direction arrows to determine in which direction the wipe

or dissolve takes place.

7. Enter a value into the Ease field (between –100 and 100). This value controls whether

the transform starts out quickly and slows near the end or starts out slowly and gains

speed. Alternatively, use the Ease slider.

8. To preview how the Timeline Effect will look, click the Update button in the upper-

right corner of the Transition dialog box.

9. When you’re finished, click OK.

Inspirational Design Model
Designed by Djojo Studios (whose site appears in this book’s color section), Langlevelater

(www.langlevelater.nl/en) is easily one of the most innovative learning environments on

the Web today. Built entirely with Flash and Dreamweaver, the site (see Figure 10.11) was

designed for the Floriade Dutch Horticultural Exhibition to teach kids about environmen-

tal issues.

Figure 10.10

The Transition 
dialog box
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Melding Djojo Studios easily recognizable, stylish illustration with an incredibly

immersive Flash-based environment, Langlevelater lets kids navigate through a series 

of virtual pavilions, each mirroring an actual pavilion at the horticultural exhibition.

Each pavilion contains topical quizzes, the successful completion of which awards kids

with tiles to build their own interactive urban landscapes.
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Figure 10.11

Djojo Studios’ 
Langlevelator

inspirational design model ■ 253

4284c10.qxd  11/18/03  9:44 PM  Page 253



4284c10.qxd  11/18/03  9:44 PM  Page 254




